CRAN Package Check Results for Package HSAR

Last updated on 2022-01-18 06:52:49 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.5.1 166.91 342.57 509.48 OK
r-devel-linux-x86_64-debian-gcc 0.5.1 133.25 273.17 406.42 OK
r-devel-linux-x86_64-fedora-clang 0.5.1 656.95 NOTE
r-devel-linux-x86_64-fedora-gcc 0.5.1 618.02 OK
r-devel-windows-x86_64-new-UL 0.5.1 138.00 349.00 487.00 OK
r-devel-windows-x86_64-new-TK 0.5.1 OK
r-patched-linux-x86_64 0.5.1 144.44 305.51 449.95 WARN
r-release-linux-x86_64 0.5.1 WARN
r-release-macos-arm64 0.5.1 NOTE
r-release-macos-x86_64 0.5.1 NOTE
r-release-windows-ix86+x86_64 0.5.1 389.00 456.00 845.00 WARN
r-oldrel-macos-x86_64 0.5.1 NOTE
r-oldrel-windows-ix86+x86_64 0.5.1 392.00 485.00 877.00 WARN

Check Details

Version: 0.5.1
Check: installed package size
Result: NOTE
     installed size is 9.1Mb
     sub-directories of 1Mb or more:
     libs 8.5Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 0.5.1
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘PropertiesAthens.Rmd’ using knitr
    Linking to GEOS 3.10.1, GDAL 3.4.1, PROJ 8.2.1; sf_use_s2() is TRUE
    ── Attaching packages ─────────────────────────────────────── tidyverse 1.3.1 ──
    ✔ ggplot2 3.3.5 ✔ purrr 0.3.4
    ✔ tibble 3.1.6 ✔ dplyr 1.0.7
    ✔ tidyr 1.1.4 ✔ stringr 1.4.0
    ✔ readr 2.1.1 ✔ forcats 0.5.1
    ── Conflicts ────────────────────────────────────────── tidyverse_conflicts() ──
    ✖ dplyr::filter() masks stats::filter()
    ✖ dplyr::lag() masks stats::lag()
    Loading required package: sp
    Loading required package: spData
    To access larger datasets in this package, install the spDataLarge
    package with: `install.packages('spDataLarge',
    repos='https://nowosad.github.io/drat/', type='source')`
    --- finished re-building ‘PropertiesAthens.Rmd’
    
    --- re-building ‘hsar.Rmd’ using knitr
    Checking rgeos availability: TRUE
    Please note that 'maptools' will be retired by the end of 2023,
    plan transition at your earliest convenience;
    some functionality will be moved to 'sp'.
    Please note that rgdal will be retired by the end of 2023,
    plan transition to sf/stars/terra functions using GDAL and PROJ
    at your earliest convenience.
    
    rgdal: version: 1.5-28, (SVN revision 1158)
    Geospatial Data Abstraction Library extensions to R successfully loaded
    Loaded GDAL runtime: GDAL 3.4.1, released 2021/12/27
    Path to GDAL shared files: /usr/share/gdal
    GDAL binary built with GEOS: TRUE
    Loaded PROJ runtime: Rel. 8.2.1, January 1st, 2022, [PJ_VERSION: 821]
    Path to PROJ shared files: /home/hornik/.local/share/proj:/usr/share/proj
    PROJ CDN enabled: FALSE
    Linking to sp version:1.4-6
    To mute warnings of possible GDAL/OSR exportToProj4() degradation,
    use options("rgdal_show_exportToProj4_warnings"="none") before loading sp or rgdal.
    rgeos version: 0.5-9, (SVN revision 684)
     GEOS runtime version: 3.10.1-CAPI-1.16.0
     Please note that rgeos will be retired by the end of 2023,
    plan transition to sf functions using GEOS at your earliest convenience.
     GEOS using OverlayNG
     Linking to sp version: 1.4-6
     Polygon checking: TRUE
    
    Loading required package: spData
    To access larger datasets in this package, install the spDataLarge
    package with: `install.packages('spDataLarge',
    repos='https://nowosad.github.io/drat/', type='source')`
    Loading required package: sf
    Linking to GEOS 3.10.1, GDAL 3.4.1, PROJ 8.2.1; sf_use_s2() is TRUE
    Quitting from lines 112-121 (hsar.Rmd)
    Error: processing vignette 'hsar.Rmd' failed with diagnostics:
    no method or default for coercing "matrix" to "dgCMatrix"
    --- failed re-building ‘hsar.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘hsar.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavors: r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.5.1
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building 'PropertiesAthens.Rmd' using knitr
    Linking to GEOS 3.9.1, GDAL 3.2.1, PROJ 7.2.1; sf_use_s2() is TRUE
    -- Attaching packages --------------------------------------- tidyverse 1.3.1 --
    v ggplot2 3.3.5 v purrr 0.3.4
    v tibble 3.1.6 v dplyr 1.0.7
    v tidyr 1.1.4 v stringr 1.4.0
    v readr 2.1.1 v forcats 0.5.1
    -- Conflicts ------------------------------------------ tidyverse_conflicts() --
    x dplyr::filter() masks stats::filter()
    x dplyr::lag() masks stats::lag()
    Loading required package: sp
    Loading required package: spData
    To access larger datasets in this package, install the spDataLarge
    package with: `install.packages('spDataLarge',
    repos='https://nowosad.github.io/drat/', type='source')`
    --- finished re-building 'PropertiesAthens.Rmd'
    
    --- re-building 'hsar.Rmd' using knitr
    Checking rgeos availability: TRUE
    Please note that 'maptools' will be retired by the end of 2023,
    plan transition at your earliest convenience;
    some functionality will be moved to 'sp'.
    Please note that rgdal will be retired by the end of 2023,
    plan transition to sf/stars/terra functions using GDAL and PROJ
    at your earliest convenience.
    
    rgdal: version: 1.5-28, (SVN revision 1158)
    Geospatial Data Abstraction Library extensions to R successfully loaded
    Loaded GDAL runtime: GDAL 3.2.1, released 2020/12/29
    Path to GDAL shared files: D:/temp/RtmpGe0Xak/RLIBS_29a0663f559d/rgdal/gdal
    GDAL binary built with GEOS: TRUE
    Loaded PROJ runtime: Rel. 7.2.1, January 1st, 2021, [PJ_VERSION: 721]
    Path to PROJ shared files: D:/temp/RtmpGe0Xak/RLIBS_29a0663f559d/rgdal/proj
    PROJ CDN enabled: FALSE
    Linking to sp version:1.4-6
    To mute warnings of possible GDAL/OSR exportToProj4() degradation,
    use options("rgdal_show_exportToProj4_warnings"="none") before loading sp or rgdal.
    Overwritten PROJ_LIB was D:/temp/RtmpGe0Xak/RLIBS_29a0663f559d/rgdal/proj
    rgeos version: 0.5-9, (SVN revision 684)
     GEOS runtime version: 3.9.1-CAPI-1.14.2
     Please note that rgeos will be retired by the end of 2023,
    plan transition to sf functions using GEOS at your earliest convenience.
     GEOS using OverlayNG
     Linking to sp version: 1.4-6
     Polygon checking: TRUE
    
    Loading required package: spData
    To access larger datasets in this package, install the spDataLarge
    package with: `install.packages('spDataLarge',
    repos='https://nowosad.github.io/drat/', type='source')`
    Loading required package: sf
    Linking to GEOS 3.9.1, GDAL 3.2.1, PROJ 7.2.1; sf_use_s2() is TRUE
    Quitting from lines 112-121 (hsar.Rmd)
    Error: processing vignette 'hsar.Rmd' failed with diagnostics:
    no method or default for coercing "matrix" to "dgCMatrix"
    --- failed re-building 'hsar.Rmd'
    
    SUMMARY: processing the following file failed:
     'hsar.Rmd'
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-windows-ix86+x86_64

Version: 0.5.1
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building 'PropertiesAthens.Rmd' using knitr
    Linking to GEOS 3.9.1, GDAL 3.2.1, PROJ 7.2.1; sf_use_s2() is TRUE
    -- Attaching packages --------------------------------------- tidyverse 1.3.1 --
    v ggplot2 3.3.5 v purrr 0.3.4
    v tibble 3.1.6 v dplyr 1.0.7
    v tidyr 1.1.4 v stringr 1.4.0
    v readr 2.1.1 v forcats 0.5.1
    -- Conflicts ------------------------------------------ tidyverse_conflicts() --
    x dplyr::filter() masks stats::filter()
    x dplyr::lag() masks stats::lag()
    Loading required package: sp
    Loading required package: spData
    To access larger datasets in this package, install the spDataLarge
    package with: `install.packages('spDataLarge',
    repos='https://nowosad.github.io/drat/', type='source')`
    --- finished re-building 'PropertiesAthens.Rmd'
    
    --- re-building 'hsar.Rmd' using knitr
    Checking rgeos availability: TRUE
    Please note that 'maptools' will be retired by the end of 2023,
    plan transition at your earliest convenience;
    some functionality will be moved to 'sp'.
    Please note that rgdal will be retired by the end of 2023,
    plan transition to sf/stars/terra functions using GDAL and PROJ
    at your earliest convenience.
    
    rgdal: version: 1.5-28, (SVN revision 1158)
    Geospatial Data Abstraction Library extensions to R successfully loaded
    Loaded GDAL runtime: GDAL 3.2.1, released 2020/12/29
    Path to GDAL shared files: D:/temp/RtmpQvSoX5/RLIBS_683031df647b/rgdal/gdal
    GDAL binary built with GEOS: TRUE
    Loaded PROJ runtime: Rel. 7.2.1, January 1st, 2021, [PJ_VERSION: 721]
    Path to PROJ shared files: D:/temp/RtmpQvSoX5/RLIBS_683031df647b/rgdal/proj
    PROJ CDN enabled: FALSE
    Linking to sp version:1.4-6
    To mute warnings of possible GDAL/OSR exportToProj4() degradation,
    use options("rgdal_show_exportToProj4_warnings"="none") before loading sp or rgdal.
    Overwritten PROJ_LIB was D:/temp/RtmpQvSoX5/RLIBS_683031df647b/rgdal/proj
    rgeos version: 0.5-9, (SVN revision 684)
     GEOS runtime version: 3.9.1-CAPI-1.14.2
     Please note that rgeos will be retired by the end of 2023,
    plan transition to sf functions using GEOS at your earliest convenience.
     GEOS using OverlayNG
     Linking to sp version: 1.4-6
     Polygon checking: TRUE
    
    Loading required package: spData
    To access larger datasets in this package, install the spDataLarge
    package with: `install.packages('spDataLarge',
    repos='https://nowosad.github.io/drat/', type='source')`
    Loading required package: sf
    Linking to GEOS 3.9.1, GDAL 3.2.1, PROJ 7.2.1; sf_use_s2() is TRUE
    Quitting from lines 112-121 (hsar.Rmd)
    Error: processing vignette 'hsar.Rmd' failed with diagnostics:
    no method or default for coercing "matrix" to "dgCMatrix"
    --- failed re-building 'hsar.Rmd'
    
    SUMMARY: processing the following file failed:
     'hsar.Rmd'
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64