CRAN Package Check Results for Package wiseR

Last updated on 2021-10-22 13:57:29 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.1 2.99 20.25 23.24 NOTE
r-devel-linux-x86_64-debian-gcc 1.0.1 2.40 16.34 18.74 NOTE
r-devel-linux-x86_64-fedora-clang 1.0.1 38.92 NOTE
r-devel-linux-x86_64-fedora-gcc 1.0.1 28.06 NOTE
r-devel-windows-x86_64 1.0.1 6.00 43.00 49.00 NOTE
r-devel-windows-x86_64-gcc10-UCRT 1.0.1 ERROR
r-patched-linux-x86_64 1.0.1 3.12 20.21 23.33 NOTE
r-patched-solaris-x86 1.0.1 47.70 NOTE
r-release-linux-x86_64 1.0.1 2.92 20.12 23.04 NOTE
r-release-macos-arm64 1.0.1 NOTE
r-release-macos-x86_64 1.0.1 NOTE
r-release-windows-ix86+x86_64 1.0.1 6.00 33.00 39.00 NOTE
r-oldrel-macos-x86_64 1.0.1 NOTE
r-oldrel-windows-ix86+x86_64 1.0.1 9.00 39.00 48.00 NOTE

Check Details

Version: 1.0.1
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64

Version: 1.0.1
Check: package dependencies
Result: NOTE
    Imports includes 22 non-default packages.
    Importing from so many packages makes the package vulnerable to any of
    them becoming unavailable. Move as many as possible to Suggests and
    use conditionally.
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 1.0.1
Check: installed package size
Result: NOTE
     installed size is 7.2Mb
     sub-directories of 1Mb or more:
     bn 7.1Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-x86_64, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64, r-oldrel-macos-x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.0.1
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘DT’ ‘DescTools’ ‘HydeNet’ ‘RBGL’ ‘Rgraphviz’ ‘arules’ ‘bnlearn’
     ‘dplyr’ ‘graph’ ‘igraph’ ‘linkcomm’ ‘missRanger’ ‘parallel’ ‘psych’
     ‘rhandsontable’ ‘rintrojs’ ‘shinyBS’ ‘shinyWidgets’ ‘shinyalert’
     ‘shinycssloaders’ ‘shinydashboard’ ‘tools’ ‘visNetwork’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 1.0.1
Check: package dependencies
Result: ERROR
    Packages required but not available: 'HydeNet', 'linkcomm', 'igraph'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-gcc10-UCRT